We kennen Excel allemaal als een breed inzetbaar Microsoft-programma. Of je het nu gebruikt om lijstjes bij te houden van bijvoorbeeld de boodschappen of je gewerkte uren óf er hele begrotingen mee maakt, Excel heeft voor ieder wat wils. Maar behalve dit heeft Excel nog veel meer te bieden, talloze functies waar je misschien nog nooit van gehoord hebt, maar die je leven wel een stuk makkelijker kunnen maken. Een van deze functies is de ALS-functie. Wil je meer weten over deze functie en over hoe jij deze kunt inzetten? Lees dan vooral verder!


De ALS-functie zorgt ervoor dat je een logische vergelijking kunt maken tussen een waarde en een verwachte waarde. Hier kunnen twee resultaten uitkomen: 1 wanneer de vergelijking waar is en 1 wanneer de vergelijking niet waar is. Simpel gezegd staat de functie voor: =ALS(iets waar is, doe dan iets, doe anders iets anders).

ALS-functie voor een simpele vergelijking:


Om hier een duidelijker beeld bij te krijgen zullen we kort bovenstaande voorbeelden behandelen.
1. In D2 vul je in: ‘=ALS(C2=”Ja”;1;2)’ Dit wil zeggen dat wanneer C2 ‘Ja’ is, in D2 een 1 moet komen en als C2 iets anders dan ‘Ja’ is, komt er een 2. Je hoeft deze code natuurlijk niet steeds opnieuw in te vullen, je kunt deze gewoon naar beneden slepen. Dan past Excel het overal zo toe.
2. In D2 vul je in: ‘=ALS(C2=1;”Ja”;”Nee”)’ Dit wil zeggen dat wanneer er in C2 ‘1’ staat, in D2 een ‘Ja’ moet komen en wanneer er iets anders in C2 staat, komt er een ‘Nee’ in D2.

LET OP: dat je in de formule precies hetzelfde invult als in de cellen (inclusief spaties etc.)!


ALS-functie voor berekening:

 

3. Naast deze simpele vergelijkingen is het ook mogelijk om de als-functie in te zetten voor berekeningen, zie voorbeeld 3. In D2 vul je dan in: ‘=ALS(C2>B2;”Buiten Budget”;”Binnen budget”)’ Dit wil zeggen wanneer C2 inderdaad groter is dan B2, het budget overschreden is. Wanneer C2 niet groter is dan B2 komt er in D2 ‘Binnen budget’ te staan.


4. Het volgende voorbeeld laat zien hoe je een getal kunt uitrekenen met de als-functie. Wanneer je bovenstaand wilt krijgen, vul je in E2 in: ‘ALS(C2>B2;C2-B2;0)’ Dit wil zeggen wanneer C2 groter is dan B2, dus buiten budget, Excel B2 moet aftrekken van C2. Zo krijg je in E2 het overschreden bedrag. Wanneer C2 niet groter is dan B2, komt er in E2 een 0.


ALS.VOORWAARDEN-functie (IFS):

Met deze functie wordt gecontroleerd of er aan een of meerdere voorwaarden wordt voldaan en wordt er een waarde aangekoppeld die wordt gekoppeld aan de éérste voorwaarden waar de waarde aan voldoet.
 

5. Wanneer je in B letters wilt toevoegen die gekoppeld zijn aan de waarden van A, vul je het volgende in: ‘ALS.VOORWAARDEN(A2>89;"A";A2>79;"B";A2>69;"C";A2>59;"D";WAAR;"F")’ Dit wil zeggen dat wanneer A2 groter is dan 89, er in B2 een A komt. Wanneer het cijfer groter is dan 79, dan komt er een B enzovoort. Wanneer het getal in A2 kleiner is dan 59, komt er een F in B2. Wanneer je een standaardresultaat wilt invoeren, vul je ‘WAAR’ in voor het laatste argument, Excel neemt dan de overeenkomende waarde wanneer er aan geen enkele andere voorwaarde wordt voldaan.


ALS in combinatie met EN-, OF- en NIET-functies:

Naast de ALS-functie op zichzelf, kan je dit ook combineren met andere Excel functies.  Wanneer je meerdere voorwaarden wilt testen, waarbij alle voorwaarden bijvoorbeeld waar of onwaar moeten zijn kan de EN-functie van pas komen. Wanneer er maar één voorwaarde waar of onwaar hoeft te zijn is de OF-functie erg handig en als je wilt checken of een voorwaarde niet aan de criteria voldoet, is de NIET-functie de oplossing. Deze functies zijn ook los van elkaar te gebruiken, maar worden meestal in combinatie met de ALS-functie ingezet. In combinatie met ALS, zien de functies er als volgt uit:
-EN: ‘=ALS(EN(iets is waar, iets anders is waar), waarde indien waar, waarde indien onwaar)’
-OF: ‘=ALS(OF(iets is waar, iets anders is waar), waarde indien waar, waarde indien onwaar)’
-NIET: ‘=ALS(NIET(iets is waar), waarde indien waar, waarde indien onwaar)’


6. In bovenstaande afbeelding staan twee voorbeelden van zowel de ALS EN-functie, ALS OF-functie en de ALS NIET-functie. Deze bespreken we een voor een.

EN-functie:
Regel 2: ‘=ALS(EN(A2>0,B2<100),WAAR, ONWAAR)’
Dit wil zeggen wanneer A2 groter is dan 0 EN B2 kleiner is dan 100, er in D2 ‘WAAR’ moet komen en anders ‘ONWAAR’. In dit geval zijn beide voorwaarden waar en wordt dus ‘WAAR’ geretourneerd. Belangrijk bij de ALS EN-functie is dat béide voorwaarden moeten kloppen, anders wordt er ‘ONWAAR’ genoteerd.
Regel 3: ‘=ALS(EN(A3="rood",B3="groen"),WAAR,ONWAAR)’
Dit wil zeggen wanneer in A3 ('blauw') = 'rood' EN B3 ('groen') is gelijk aan 'groen'. In dit geval is alleen de tweede voorwaarde waar, dus is het resultaat is ‘ONWAAR’.

OF-functie:
Regel 4: ‘=ALS(OF(A4>0,B4<50),WAAR, ONWAAR)
Dit wil zeggen wanner A4 groter is dan 0 OF wanneer B4 kleiner is dan 50, dan komt er ‘WAAR’, anders komt er ‘ONWAAR’. In dit geval is alleen de eerste voorwaarde waar, maar aangezien er bij een OF maar één argument waar hoeft te zijn, komt er met deze formule alsnog ‘WAAR’.
Regel 5: ‘=ALS(OF(A5="rood",B5="groen"),WAAR,ONWAAR)’
Dit wil zeggen dat wanneer A5 gelijk is aan 'rood' OF B5 aan 'groen', dan komt er ‘WAAR’, is dit niet get geval komt er ‘ONWAAR’. In dit geval is het tweede argument waar, dus met behulp van de formule komt er ‘WAAR’.

NIET-functie:
Regel 6: ‘=ALS(NIET(A6>50),WAAR,ONWAAR)’
Wanneer A6 NIET groter is dan 50, komt er ‘WAAR’, anders ‘ONWAAR’. In dit geval is 25 niet groter dan 50, dus de formule noteert ‘WAAR’.
Regel 7: ‘=ALS(NIET(A7="rood"),WAAR,ONWAAR)’
Als A7 NIET gelijk is aan 'rood', komt er ‘WAAR’ en anders ‘ONWAAR’.


Word een Excel expert bij Master it:

Meer te weten komen over alle functies van Excel en hiermee aan de slag gaan? We bieden verschillende Exceltrainingen, afgestemd op jouw niveau en leerdoelen. Wil je beginnen bij de basis, start dan met een 2-daagse Excel basistraining. Zijn bovenstaande formules voor jou een eitje en wil je dieper ingaan op macro’s en draaitabellen? Schrijf je dan in voor Excel Vervolg. Ben je een finance professional, dan is de Excel for Financials training wellicht goed afgestemd op jouw wensen. Is data analyse meer jouw ding? Dan hebben we ook een geavanceerdere Analyzing Data with Excel training voor jou!Natuurlijk is maatwerk ook mogelijk, waarbij we goed kijken naar jouw wensen. Zo verzorgen wij ook incompany trainingen waarin jouw gehele team efficiënter laten werken door onze Exceltrainingen. Kijk hier voor meer informatie.

Met onze Active Learning lesmethode ga je actief met de lesstof aan de slag. Dit betekent dat je niet naar saaie klassikale uitleg hoeft te luisteren, maar zelf met de theorie én de praktijk aan de slag gaat in kleine klassen. Zo krijg je veel persoonlijke aandacht en kun je ook praktijkcases meenemen zodat je de opgedane kennis direct in de praktijk kunt brengen. Dit hoef je natuurlijk niet alleen te doen, maar onder begeleiding van een gecertificeerde trainer die er vol voor gaat om jou te helpen je leerdoelen zo efficiënt mogelijk bereiken!