Er zijn in Excel verschillende manieren om in een lijst met data subtotalen te berekenen. Natuurlijk kun je de lijst met gegevens zelf in stukjes hakken en voor ieder stukje een som maken. Niet erg handig en kost veel tijd. Hoe dit dan wel slim te doen? Excel biedt ons verschillende mogelijkheden.

Bekijk ook onze GRATIS tutorial Excel; tabellen, grafieken en draaitabellen!

In dit artikel nemen we als uitgangspunt de lijst die hieronder wordt weergegeven:



Methode 1: functie =SOM.ALS


De eerste methode is gebruik te maken van functies. De functie =SOM.ALS kan hier handig zijn. In deze functie gebruik je drie argumenten: de kolom waarin de gegevens staan waarop je wilt groeperen, het criterium waarop je wilt filteren en tot slot het bereik waarin de op te tellen waarden staan. In bovenstaand lijst willen we het totale verkoopbedrag weten van alle Cadillacs. De functie ziet er dan zo uit: =SOM.ALS(A2:A39;”cadillac”;E2:E39).



Methode 2: functie =SOMMEN.ALS


Lastiger wordt het wanneer we niet alleen op Merk maar ook op Kleur willen filteren: dus het totale verkoopbedrag van alle zwarte Cadillacs. Hier biedt de functie =SOMMEN.ALS uitkomst.

Deze functie ziet er als volgt uit: =SOMMEN.ALS(E2:E39;A2:A39;"cadillac";C2:C39;"black").



Zoals je ziet kunnen we nog meer criteria toevoegen: alle zwarte cadillacs met een V8, enz.


Methode 3: functie =DBSOM


Iets omslachtiger is het gebruik van de functie =DBSOM. Deze functie maakt gebruik van een criteriumgebied waarin de kolomkoppen staan van de te filteren kolommen, en daaronder de criteriawaarden. Hier berekenen we het verkoopbedrag van alle zwarte Cadillacs. De naam Database in het eerste argument is een naam die de gehele lijst omvat, kolomkoppen incluis! =DBSOM(Database;E1;M1:N1).



Zetten we de criteria in verschillende rijen, dan berekenen we het verkoopbedrag van alle Cadillacs en van alle andere auto’s, zolang deze maar zwart zijn.



Methode 4: subtotalen


Een elegante methode is het gebruik van de optie Subtotalen. Hiervoor sorteren we de lijst op de kolom die we als groepeerkolom willen gebruiken (Merk). We klikken in de lijst en gaan naar Gegevens-Subtotaal. We geven aan welke kolom de groepering bevat, welke berekening we willen uitvoeren en in welke kolom de te berekenen waarden staan.



Dit is het resultaat:



Methode 5: tabel


De laatste optie is het gebruik van de Tabel. Een Tabel is een object in een Excel blad dat een aantal fijne eigenschappen bezit. Een ervan is dat we erin kunnen filteren en kunnen rekenen.

Klik in de lijst en ga naar Invoegen-Tabel, en klik OK.

Er verschijnt een Hulpmiddelen voor tabellen tabblad, hierop staat de optie Totaalrij. Kies in de totaalrij de cel onder de kolom die berekent moet worden, en kies in de dropdownlijst de gewenste functie. Gebruik het autofilter dat automatisch in de kolomkoppenrij verschijnt om te filteren, en de totaalrij laat de berekende waarde zien.



Draaitabellen


We zouden ook nog een Draaitabel kunnen maken, maar daarover vind je meer in onze gratis Tutorial Excel; tabellen, grafieken en draaitabellen!

Veel succes en Excelplezier!